default.nix 564 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. { config, pkgs, ... }:
  2. {
  3. programs.zsh.enable = true;
  4. programs.mtr.enable = true;
  5. environment.systemPackages = with pkgs; [
  6. curl
  7. vim
  8. neovim
  9. neovim-remote
  10. git
  11. git-lfs
  12. feh
  13. ripgrep
  14. jq
  15. yq
  16. tree
  17. fzf
  18. dnsutils
  19. httpie
  20. htop
  21. bc
  22. pv
  23. openssl
  24. pwgen
  25. gnupg
  26. whois
  27. traceroute
  28. gnumake
  29. tig
  30. unzip
  31. zip
  32. shellcheck
  33. any-nix-shell
  34. tmux-cssh
  35. # work
  36. awscli
  37. docker
  38. docker_compose
  39. amazon-ecr-credential-helper
  40. python37Packages.cfn-lint
  41. ];
  42. }