configuration.nix 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Edit this configuration file to define what should be installed on
  2. # your system. Help is available in the configuration.nix(5) man page
  3. # and in the NixOS manual (accessible by running ‘nixos-help’).
  4. { config, pkgs, ... }:
  5. {
  6. imports =
  7. [
  8. ./hardware.nix
  9. ./local.nix
  10. ./includes/cli
  11. ./includes/desktop
  12. ./includes/local-dns
  13. ./includes/kubernetes
  14. ];
  15. nixpkgs.config.allowUnfree = true;
  16. networking.networkmanager.enable = true;
  17. i18n = {
  18. consoleFont = "Lat2-Terminus16";
  19. consoleKeyMap = "us";
  20. defaultLocale = "en_US.UTF-8";
  21. };
  22. # Set your time zone.
  23. time.timeZone = "Asia/Tokyo";
  24. # Enable sound.
  25. sound.enable = true;
  26. hardware.pulseaudio.enable = true;
  27. virtualisation.libvirtd = {
  28. enable = true;
  29. onBoot = "ignore";
  30. };
  31. # Define a user account. Don't forget to set a password with ‘passwd’.
  32. users.users.thomas = {
  33. isNormalUser = true;
  34. extraGroups = [ "wheel" "video" "networkmanager" "libvirt" ];
  35. shell = pkgs.zsh;
  36. };
  37. nix.gc = {
  38. automatic = true;
  39. options = "--delete-older-then 14d";
  40. };
  41. systemd.timers.nix-gc.timerConfig.Persistent = true;
  42. # This value determines the NixOS release with which your system is to be
  43. # compatible, in order to avoid breaking some software such as database
  44. # servers. You should change this only after NixOS release notes say you
  45. # should.
  46. system.stateVersion = "19.09"; # Did you read the comment?
  47. }