123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869 |
- { config, pkgs, ... }:
- {
- imports =
- [
- ./hardware.nix
- ./local.nix
- ./includes/cli
- ./includes/desktop
- ./includes/local-dns
- ./includes/kubernetes
- ];
- nixpkgs.config.allowUnfree = true;
- networking.networkmanager.enable = true;
- console.font = "Lat2-Terminus16";
- console.keyMap = "us";
- i18n.defaultLocale = "en_US.UTF-8";
-
- time.timeZone = "Asia/Tokyo";
-
- sound.enable = true;
- hardware.pulseaudio.enable = true;
- virtualisation.libvirtd = {
- enable = true;
- onBoot = "ignore";
- };
-
- users.users.thomas = {
- uid = 1000;
- isNormalUser = true;
- extraGroups = [ "wheel" "video" "networkmanager" "libvirtd" ];
- shell = pkgs.zsh;
- subUidRanges = [
- { count = 65535; startUid = 100001; }
- ];
- subGidRanges = [
- { count = 65535; startGid = 100001; }
- ];
- };
- users.groups.thomas = {
- gid = 1000;
- members = [ "thomas" ];
- };
- nix.gc = {
- automatic = true;
- options = "--delete-older-than 14d";
- };
- systemd.timers.nix-gc.timerConfig.Persistent = true;
-
-
-
-
- system.stateVersion = "19.09";
- }
|