12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758 |
- { config, pkgs, ... }:
- {
- imports =
- [
- ./hardware.nix
- ./local.nix
- ./includes/cli
- ./includes/desktop
- ./includes/local-dns
- ./includes/kubernetes
- ];
- nixpkgs.config.allowUnfree = true;
- networking.networkmanager.enable = true;
- i18n = {
- consoleFont = "Lat2-Terminus16";
- consoleKeyMap = "us";
- defaultLocale = "en_US.UTF-8";
- };
-
- time.timeZone = "Asia/Tokyo";
-
- sound.enable = true;
- hardware.pulseaudio.enable = true;
- virtualisation.libvirtd = {
- enable = true;
- onBoot = "ignore";
- };
-
- users.users.thomas = {
- isNormalUser = true;
- extraGroups = [ "wheel" "video" "networkmanager" "libvirtd" ];
- shell = pkgs.zsh;
- };
- nix.gc = {
- automatic = true;
- options = "--delete-older-than 14d";
- };
- systemd.timers.nix-gc.timerConfig.Persistent = true;
-
-
-
-
- system.stateVersion = "19.09";
- }
|