default.nix 699 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. { config, pkgs, ... }:
  2. let
  3. cssh = pkgs.linkFarm "cssh" [{
  4. name = "bin/cssh";
  5. path = "${pkgs.tmux-cssh}/bin/tmux-cssh";
  6. }];
  7. in
  8. {
  9. programs.zsh.enable = true;
  10. programs.mtr.enable = true;
  11. environment.systemPackages = with pkgs; [
  12. curl
  13. vim
  14. neovim
  15. neovim-remote
  16. git
  17. git-lfs
  18. feh
  19. ripgrep
  20. jq
  21. yq
  22. tree
  23. fzf
  24. dnsutils
  25. httpie
  26. htop
  27. bc
  28. pv
  29. openssl
  30. pwgen
  31. gnupg
  32. whois
  33. traceroute
  34. gnumake
  35. tig
  36. unzip
  37. zip
  38. shellcheck
  39. any-nix-shell
  40. tmux-cssh
  41. cssh
  42. # work
  43. awscli
  44. docker
  45. docker_compose
  46. amazon-ecr-credential-helper
  47. python37Packages.cfn-lint
  48. _1password
  49. ];
  50. }