configuration.nix 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Edit this configuration file to define what should be installed on
  2. # your system. Help is available in the configuration.nix(5) man page
  3. # and in the NixOS manual (accessible by running ‘nixos-help’).
  4. { config, pkgs, ... }:
  5. {
  6. imports =
  7. [
  8. ./hardware.nix
  9. ./local.nix
  10. ./includes/cli
  11. ./includes/desktop
  12. ./includes/local-dns
  13. ./includes/kubernetes
  14. ];
  15. nixpkgs.config.allowUnfree = true;
  16. networking.networkmanager.enable = true;
  17. i18n = {
  18. consoleFont = "Lat2-Terminus16";
  19. consoleKeyMap = "us";
  20. defaultLocale = "en_US.UTF-8";
  21. };
  22. # Set your time zone.
  23. time.timeZone = "Asia/Tokyo";
  24. # Enable sound.
  25. sound.enable = true;
  26. hardware.pulseaudio.enable = true;
  27. virtualisation.libvirtd = {
  28. enable = true;
  29. onBoot = "ignore";
  30. };
  31. # Define a user account. Don't forget to set a password with ‘passwd’.
  32. users.users.thomas = {
  33. uid = 1000;
  34. isNormalUser = true;
  35. extraGroups = [ "wheel" "video" "networkmanager" "libvirtd" ];
  36. shell = pkgs.zsh;
  37. subUidRanges = [
  38. { count = 65535; startUid = 100001; }
  39. ];
  40. subGidRanges = [
  41. { count = 65535; startGid = 100001; }
  42. ];
  43. };
  44. users.groups.thomas = {
  45. gid = 1000;
  46. members = [ "thomas" ];
  47. };
  48. nix.gc = {
  49. automatic = true;
  50. options = "--delete-older-than 14d";
  51. };
  52. systemd.timers.nix-gc.timerConfig.Persistent = true;
  53. # This value determines the NixOS release with which your system is to be
  54. # compatible, in order to avoid breaking some software such as database
  55. # servers. You should change this only after NixOS release notes say you
  56. # should.
  57. system.stateVersion = "19.09"; # Did you read the comment?
  58. }