default.nix 811 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. { config, pkgs, ... }:
  2. let
  3. cssh = pkgs.linkFarm "cssh" [{
  4. name = "bin/cssh";
  5. path = "${pkgs.tmux-cssh}/bin/tmux-cssh";
  6. }];
  7. in
  8. {
  9. programs.zsh.enable = true;
  10. programs.mtr.enable = true;
  11. environment.systemPackages = with pkgs; [
  12. curl
  13. vim
  14. neovim
  15. neovim-remote
  16. git
  17. git-lfs
  18. gitAndTools.delta
  19. gitAndTools.git-absorb
  20. gitAndTools.gitstatus
  21. feh
  22. ripgrep
  23. jq
  24. yq
  25. tree
  26. fzf
  27. dnsutils
  28. httpie
  29. htop
  30. bc
  31. pv
  32. openssl
  33. pwgen
  34. gnupg
  35. whois
  36. traceroute
  37. gnumake
  38. tig
  39. unzip
  40. zip
  41. shellcheck
  42. any-nix-shell
  43. tmux-cssh
  44. cssh
  45. file
  46. bat
  47. fd
  48. # work
  49. awscli
  50. docker
  51. docker_compose
  52. amazon-ecr-credential-helper
  53. python37Packages.cfn-lint
  54. _1password
  55. keyutils
  56. ];
  57. }