123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960 |
- { config, pkgs, ... }:
- let
- cssh = pkgs.linkFarm "cssh" [{
- name = "bin/cssh";
- path = "${pkgs.tmux-cssh}/bin/tmux-cssh";
- }];
- in
- {
- programs.zsh.enable = true;
- programs.mtr.enable = true;
- environment.systemPackages = with pkgs; [
- curl
- vim
- neovim
- neovim-remote
- git
- git-lfs
- gitAndTools.delta
- gitAndTools.git-absorb
- gitAndTools.gitstatus
- feh
- ripgrep
- jq
- yq
- tree
- fzf
- dnsutils
- httpie
- htop
- bc
- pv
- openssl
- pwgen
- gnupg
- whois
- traceroute
- gnumake
- tig
- unzip
- zip
- shellcheck
- any-nix-shell
- tmux-cssh
- cssh
- file
- bat
- fd
- # work
- awscli
- docker
- docker_compose
- amazon-ecr-credential-helper
- python37Packages.cfn-lint
- _1password
- keyutils
- ];
- }
|